SMFPortal.de

Willkommen !

Autor Thema: zuviele sleeps auf die Datenbank ... (!?)  (Gelesen 5989 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Apollon

  • Mitglied
  • **
  • Beiträge: 25
zuviele sleeps auf die Datenbank ... (!?)
« am: 20. Februar 2009, 22:16:42 »
Alles fing vielleicht um den 13.02. um 0.07 Uhr mit der email an dass ich datenbankfehler haette.
das gleiche nochmal in der nacht vom 16 auf den 17.02 auch um 0.07 Uhr (Huch?)

Text:
There has been a problem with the database!
This is a notice email to let you know that SMF could not connect to the database, contact your host if this continues.


am 17.02 gegen 17 h  bekam ich dann folgende email:
Hallo! bonjour! ciao! hola! olà! and hello!

Ihre webseite macht extrem viele sleep verbindungen zur mysql datenbank, was
ist hier los? Die verbindungen werden nicht sauber geschlossen. Bitte
überprüfen sie ihre software und geben sie uns bescheid.
 

[root@D6 ~]# mysqladmin -uadmin Bäh!`cat /etc/psa/.psa.shadow` processlist

+--------+---------+-----------+----------+---------+------+-------+--------
----
------+

| Id     | User    | Host      | db       | Command | Time | State | Info
|

+--------+---------+-----------+----------+---------+------+-------+--------
----
------+

| 98     | admin   | localhost | psa      | Sleep   | 158  |       |
|

| 130658 | Apollon | localhost | smfdaten | Sleep   | 229  |       |
|

| 149735 | Apollon | localhost | smfdaten | Sleep   | 1075 |       |
|

| 149762 | Apollon | localhost | smfdaten | Sleep   | 298  |       |
|

| 153781 | Apollon | localhost | smfdaten | Sleep   | 276  |       |
|

| 172943 | Apollon | localhost | smfdaten | Sleep   | 336  |       |
|

| 173004 | Apollon | localhost | smfdaten | Sleep   | 228  |       |
|

| 174220 | Apollon | localhost | smfdaten | Sleep   | 138  |       |
|

| 174354 | Apollon | localhost | smfdaten | Sleep   | 139  |       |
|

| 174480 | Apollon | localhost | smfdaten | Sleep   | 1788 |       |
|

| 174519 | Apollon | localhost | smfdaten | Sleep   | 136  |       |
|

| 185087 | Apollon | localhost | smfdaten | Sleep   | 245  |       |
|

| 187729 | Apollon | localhost | smfdaten | Sleep   | 338  |       |
|

| 187753 | Apollon | localhost | smfdaten | Sleep   | 166  |       |
|

| 188021 | Apollon | localhost | smfdaten | Sleep   | 296  |       |
|

| 189535 | Apollon | localhost | smfdaten | Sleep   | 1457 |       |
|

| 192241 | Apollon | localhost | smfdaten | Sleep   | 136  |       |
|

| 192276 | Apollon | localhost | smfdaten | Sleep   | 274  |       |
|

| 192322 | Apollon | localhost | smfdaten | Sleep   | 244  |       |
|

| 193283 | Apollon | localhost | smfdaten | Sleep   | 169  |       |
|

| 193399 | admin   | localhost |          | Query   | 0    |       | show
proces
slist |

+--------+---------+-----------+----------+---------+------+-------+--------
----
------+

[root@D6 ~]#

daraufhin meldete ich mich beim support per skype:

[17.02.2009 18:11:00] Apollon : hallo - habe gearde die email bekommen dass ich viele "sleep"verbindungen habe zur sql datenbank ... was ist damit gemeint ?
[17.02.2009 18:12:04] BIGhosting Support Helpline : dass ihr programm zuviele verbindungen zum mysql server nicht sauber schliesst
[17.02.2009 18:12:10] Support Helpline : dadurchentstehen die sleep
[17.02.2009 18:12:15] Support Helpline : und blockieren
[17.02.2009 18:12:25] Support Helpline : irgendwann stürzt der server ab
[17.02.2009 18:12:43 Support Helpline : klären sie ab warum die verbindungen nicht geschlossen werden
[17.02.2009 18:13:04] Support Helpline : ein paar sagen wir ja nichts, aber sie haben bis 20 stk ..
[17.02.2009 18:13:05] Apollon : wie kann sowas passieren - das ist das simple machines forum
[17.02.2009 18:13:23] Support Helpline : fragen sie dort mal im support, evt gibt ein update
[17.02.2009 18:13:28] Support Helpline : kenne das teil nicht
[17.02.2009 18:13:52] Apollon : ja einen update gibt es wohl - aber das kann ich nicht installieren
[17.02.2009 18:14:37] Apollon : es kommt die meldung dass der ordner "forum" nicht existieren wuerde
[17.02.2009 18:15:00] Apollon : bastel da schon seit tagen rum
[17.02.2009 18:16:20] Apollon : wodurch kann dieses "nicht sauber schliessen" zustande kommen ?
[17.02.2009 18:35:47] Apollon : ich setz mich auf jeden fall jetzt noch mal a dran
[17.02.2009 18:39:47] Support Helpline : yep tx
[18.02.2009 01:12:35] Apollon : hallo eine Antwort ...
[18.02.2009 01:13:32] Apollon : ist zwar aus einem support forum fuer ein portal - betrift aber das problem das ich das forum nicht updaten kann :
[18.02.2009 01:13:35] Apollon : The consensus seems to be that this is most likely configuration issues with your host, either with permissions on files/folders, or security policies in PHP.

At this point, I would suggest that you check with your host and tell them what problems you are having and see if they can help you get this fixed.  Feel free to send them a link to this topic so that they can read it and if that doesn't help you should next go to SMF and tell them what's going on with not being able to install the update through package manager and see what they have to say about it.

We will leave this open until you come back and tell us what the status is.
[18.02.2009 01:13:47] Apollon : http://www.tinyportal.net/index.php/topic,27138.new.html#new
[14:34:38] Apollon : forum ist nach viel stress und hilfe durch die entwickler auf dem neusten stand...
[14:35:42] Apollon : frage ist jetzt (fuer mich)  wodurch entstanden diese sleeps ? ( entstehen diese auch, wenn jemand versucht von aussen massiv auf das forum zuzugreifen ?)
[14:35:47] Apollon : Gruss
[17:41:05] BIGhosting Support Helpline : | 532662 | Apollon | localhost | smfdaten   | Sleep   | 634  |       |   


das Problem meines providers scheint sich aber nicht erledigt zu haben ......
14:34:38] Apollon : forum ist nach viel stress und hilfe  auf dem neusten stand...
[14:35:42] Apollon : frage ist jetzt (fuer mich)  wodurch entstanden diese sleeps ? ( entstehen diese auch, wenn jemand versucht von aussen massiv auf das forum zuzugreifen ?)

[17:41:05]  Support Helpline : | 532662 | Apollon | localhost | smfdaten   | Sleep   | 634  |       |                  |
| 553174 | Apollon | localhost | smfdaten   | Sleep   | 603  |       |                  |
| 560172 | Apollon | localhost | smfdaten   | Sleep   | 532  |       |                  |
| 560195 | Apollon | localhost | smfdaten   | Sleep   | 160  |       |                  |
| 560204 | Apollon | localhost | smfdaten   | Sleep   | 161  |       |                  |
| 560321 | Apollon | localhost | smfdaten   | Sleep   | 564  |       |                  |
| 560364 | Apollon | localhost | smfdaten   | Sleep   | 556  |       |                  |
| 560422 | Apollon | localhost | smfdaten   | Sleep   | 631  |       |                  |
| 560423 | Apollon | localhost | smfdaten   | Sleep   | 577  |       |                  |
| 561437 | Apollon | localhost | smfdaten   | Sleep   | 571  |       |                  |
| 561531 | Apollon | localhost | smfdaten   | Sleep   | 137  |       |                  |
| 562753 | Apollon | localhost | smfdaten   | Sleep   | 1499 |       |                  |
| 562767 | Apollon | localhost | smfdaten   | Sleep   | 518  |       |                  |
| 562768 | Apollon | localhost | smfdaten   | Sleep   | 137  |       |                  |
| 562799 | Apollon | localhost | smfdaten   | Sleep   | 986  |       |                  |
| 566998 | Apollon | localhost | smfdaten   | Sleep   | 537  |       |                  |
| 568561 | Apollon | localhost | smfdaten   | Sleep   | 993  |       |                  |
| 570117 | Apollon | localhost | smfdaten   | Sleep   | 1055 |       |                  |
| 571703 | Apollon | localhost | smfdaten   | Sleep   | 131  |       |                  |
[17:41:16]  Support Helpline : problem besteht immer noch
[17:46:02] Apollon : ? dann liegt es nicht an der software des Forums... die ist jetzt auf dem aktuellen stand mit hilfe des suportes ...
[17:51:52]  Support Helpline : ja dann ist die software nichts wert, die sollen schauen dass die verbindungen sauber geschlossen werden, das ist hier das problem
[17:53:07] Apollon : hmm .. die software ist zwar frei, wird aber von von weitaus groesseren seiten genutzt als meine
[17:53:23] Apollon : ich werde das noch mal anbringen mit den sleeps

Puh ...
das ist der verlauf ...
und jetzt ihr dran als die experten.
was kann da los/e sein ?

Gruss

Apollon

TE

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #1 am: 20. Februar 2009, 22:34:06 »
ich würde mal, wie schon im anderen Topic drauf angesprochen, darauf tippen, daß du im SMF persistente Verbindungen aktiv hast. Je nach Konfiguration des MySQL-Servers / PHP kann das schonmal vorkommen ;) .. entweder du deaktivierst im SMF die persistente Datenbankverbidung ( Admin - Server-Einstellungen - Benutze dauerhafte Datenbankverbindung << da den Haken rausnehmen) oder dein Provider editiert seine php.ini und verbietet dort den pconnect.

Ist das so ein "ich biete supertolle Leistungen für 30 Cent auf meinem bei Strato gemieteten RootServer - Provider"?

Apollon

  • Mitglied
  • **
  • Beiträge: 25
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #2 am: 20. Februar 2009, 23:42:24 »
[23:36:03] Apollon : - wenn diese sleeps erst seit ein paar tagen auftreten - kann es auch nicht direkt mit der software des forums zu tun haben (meine meinung) - die entwickler und supporter weisen das problem auch erstmal zurueck. wie gesagt es ist eins der besten und sichersten freien foren und kein abfall - viele grosse Forenbetreiber nutzen es und haben keine sleep prob. (die ich ja vorher auch nicht hatte)  http://www.simplemachines.org/ - dt support => http://www.smfportal.de/index.php/  -- weiss jetzt also auch nicht so richtig wie man das stoppen kann.
[23:36:50] Apollon : dauerhafte Datenbankverbindung - Erhöht die Geschwindigkeit zur Datenbank, indem eine Verbindung dauerhaft aufrecht erhalten wird. Wenn Sie einen dedizierten Server benutzen, könnte es Probleme mit Ihrem Host geben.
[23:37:00] Apollon : das koennte der Fehler schon sein ...
[23:38:21] Apollon : die option wurde jetzt erstmal raus genommen.
[23:40:42] Support Helpline : na ja wie lange dass es besteht kann ich nicht sagen, wir sind ja erst darauf gestossen nach langem suchen. das mit dem sleep ist sicher ein programmiertehnisches problem, es geht doch nicht an dass ihr programm 20 verbindungen aufrecht erhält damit es schneller läuft und dadurch andere kunden leiden. wenn man solche resourchen will benötigt man einne eigenen rootserver. wire überlegen uns die verbidungen pro user auf 10 zu drosseln bis die autoren dort das problem gelöst haben
« Letzte Änderung: 21. Februar 2009, 02:07:12 von Apollon »

stard

  • mitten in der
  • Ehrenmitglied
  • *****
  • Beiträge: 3284
  • ach, das war eine frage?!
    • Das Computer Forum
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #3 am: 21. Februar 2009, 08:09:36 »
Zitat
[17.02.2009 18:13:04] Support Helpline : ein paar sagen wir ja nichts, aber sie haben bis 20 stk ..

wie gesagt, 20 prozesse im sleep modus sollten eigentlich keinen datenbankserver wirklich belasten. das ist das problem mit den ganzen billighostern, keine ahnung von garnichts und dann eine firma aufmachen wollen ::)

sehe ich das richtig das das ein vserver ist? sag mal ruhig bei wem der gehostet ist und was du zahlst, eventuell kann ich dir ein paar profis empfehlen ;)

Zitat
wenn man solche resourchen will benötigt man einne eigenen rootserver

für 20 besucher  ;D sehr schön ...
why so serious?

TE

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #4 am: 21. Februar 2009, 09:11:38 »
Apollon, hast du irgendwelche Dateien in deinem Forum manuell editiert? ggf. irgendein SQL-Statement, was eine Verbindung offenhält und nicht wieder schließt?

Tipps für deinen Provider:
wait_timeout in der my.cnf (Config Datei des MySQL-Servers) runterschrauben.
mysql.allow_persistent=Off (wenn ihn persistente Verbindungen "nerven")

Nur mal so am Rande: Das SMF ist programmiertechnisch eines der saubersten und sichersten Forensysteme, die auf dem Markt zu kriegen sind. Das wird dir jeder PHP-Entwickler bestätigen können.


Ferrika

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #5 am: 21. Februar 2009, 10:36:51 »
Hält die Shoutbox nicht eine permanente Verbindung zur Datenbank?

Apollon, hast Du eine Shoutbox installiert?

Thorsten, Deinen letzten Satz mußt Du mal im Serversupport-Forum oder bei WBB loslassen *g* (Was nicht heisst, dass ich Dir nicht zustimme)

Neakro

  • Spezialist
  • ****
  • Beiträge: 4500
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #6 am: 21. Februar 2009, 12:28:17 »
So sieht es aktuell bei uns aus. Es laufen eigentlich nur SMF:

Code
mysql> show processlist;
+--------+-----------+-----------------+-----------+---------+------+-------+------------------+
| Id     | User      | Host            | db        | Command | Time | State | Info             |
+--------+-----------+-----------------+-----------+---------+------+-------+------------------+
| 172384 | justauser | localhost       | justauser | Sleep   |  178 |       | NULL             |
| 239832 | justauser | localhost:41190 | justauser | Sleep   |  289 |       | NULL             |
| 239847 | justauser | localhost:41199 | justauser | Sleep   |   98 |       | NULL             |
+--------+-----------+-----------------+-----------+---------+------+-------+------------------+

Aber gerade ist ja auch nicht viel los ;D

TE

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #7 am: 21. Februar 2009, 12:48:28 »
das kann ich toppen: ;)

Code
mysql> show processlist;
+---------+-------+-----------+-------------+---------+------+-------+------------------+
| Id      | User  | Host      | db          | Command | Time | State | Info             |
+---------+-------+-----------+-------------+---------+------+-------+------------------+
| 1426992 | root  | localhost | NULL        | Query   | 0    | NULL  | show processlist |
| 1427016 | web21 | localhost | usr_web21_1 | Sleep   | 0    |       | NULL             |
+---------+-------+-----------+-------------+---------+------+-------+------------------+
2 rows in set (0.00 sec)

und ja, das ist ein Server mit etwa 400 gehosteten Domains von etwa 150 Kunden und mehreren (kleinen) und größeren SMF-Foren.

Spawn

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #8 am: 21. Februar 2009, 12:54:03 »
Angeber!  :P ;D

Apollon

  • Mitglied
  • **
  • Beiträge: 25
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #9 am: 21. Februar 2009, 13:06:29 »
Also der reihe nach …

@stard,

das Forum und seite/n sind gehostet bei
http://www.bighosting.biz/de/index.htm
ich weiss jetzt geht es los im sinne billighoster.
Aber ich habe keine kohlen….. und bis jetzt entgegen allen unkenrufen die ich nat auch vorher hatte, gab es nie ernsthafte probs. Support anfragen werden nullommanix erledigt (in diesem fall jetzt bin ich allerdings etwas sauer …)

@TE
NEIN, nichts manipuliert, (bis auf das forenbild oben links) , kein Mod installiert. (obwohl ich das ja gern wuerde.)
Die „Tipps“ hab ich mal so weitergegeben …..

Auch dein datenbank auszug …..

@Ferika
NEIN keine shoutbox installiert …(siehe oben)


Gruss

Neakro

  • Spezialist
  • ****
  • Beiträge: 4500
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #10 am: 21. Februar 2009, 13:29:13 »
Ja, da sind 20 sleeps echt zu viel...

TE

  • Gast
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #11 am: 21. Februar 2009, 13:42:12 »
Nochmal zum Thema persistente Verbinungen unter MySQL zur Erläuterung:

MySQL kann man per connect() oder per pconnect() ansprechen. Im Shared-Hosting-Bereich solltem an grundsätzlich mit connect() arbeiten, das pconnect() (die dauerhafte DB-Verbinundung) ist eigentlich eher für den Unternehmens-Einsatz gedacht, wo man auf einem dedizierten Server eine Applikation betreibt.  

Das "Problem" beim pconnect ist, daß es eben die Verbinung zur Bank bis zu einem gewissen Timeout offenhält und das kann im Shared-Hosting-Bereich, wo eben unter Umständen mehrere Hundert bis mehrere Tausend User auf einem Server liegen ziemlich belastend sein.

Ein Grund, warum ich auf meinen Shared-Servern das pconnect in der my.cnf und in der php.ini deaktiviert habe. Die Argumentation deines Hosters ist da im gewissen Grade nachvollziehbar, allerdings kann man auch von einem Hoster dazu

a) eine vernünftige Erklärung erwarten
b) kann der Hoster Mechanismen nutzen, um sich im Ernstfall davor zu schützen.

Apollon

  • Mitglied
  • **
  • Beiträge: 25
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #12 am: 23. Februar 2009, 07:18:56 »
keine sleeps mehr ..
die dauerhafte anbindung zur datenbank war wohl der fehler, wie vermutet,
von daher thema geloest.  :!.!:

vielleicht baut ihr nen kl. text in die hilfe ein:
option nicht ankreuzen bei "Billighostern" ...  :\

Gruss

Apollon

stard

  • mitten in der
  • Ehrenmitglied
  • *****
  • Beiträge: 3284
  • ach, das war eine frage?!
    • Das Computer Forum
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #13 am: 23. Februar 2009, 09:59:56 »
Zitat
die dauerhafte anbindung zur datenbank war wohl der fehler, wie vermutet,[...]

da fällt mir der alte spruch ein "es ist ein feature, kein bug" ;) aber gut das das problem behoben ist. wobei die frage natürlich bleibt wo die 20 prozesse herkommen, normalerweise sollte das mit den persistenten verbindungen ja funktionieren. aber das kann wohl nur dein hoster klären ...
why so serious?

adi211

  • Mitglied
  • **
  • Beiträge: 1
  • Geschlecht: Männlich
Re: zuviele sleeps auf die Datenbank ... (!?)
« Antwort #14 am: 04. Juni 2013, 22:55:37 »
danke. war auch bei mir der Fehler.
Allerdings war die Option mit der permanenten Verbindung bei Server-Einstellungen nicht angehakt, aber trotzdem aktiv.

Darum die Lösung. Erst aktivieren --> Speichern --> wieder deaktivieren. Dann ging es und keine Sleep Prozesse mehr :-)

 

Internes

Nutzungsbedingungen Impressum

Wissenswertes

Hilfe Knowledge Base

Nützliches

Downloads Socialmedia