SMFPortal.de

Willkommen !

Autor Thema: Aeva Media - SMF 1.1.11  (Gelesen 1280 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

RayyBan

  • Mitglied
  • **
  • Beiträge: 5
Aeva Media - SMF 1.1.11
« am: 08. Mai 2010, 20:01:48 »
Hallo zusammen,

ich habe jetzt wirklich das komplette Forum durchwühlt und meinen Code auseinander genommen. Irgendwie habe ich ein Blackout  :???: (vielleicht auch zu wenig PHP-Kenntnisse)
Ich möchte den Media Button bei meinem Theme einfügen. Vielleicht kann mir jemand auf die Schnelle sagen, wie ich meinen Code anpassen muss. Falls nicht, muss ich mich morgen nochmal durchwühlen.
usw....
Das sind meine Buttons:


// Show the [home] button.
   echo '<li><a' , $current_action=='home' ? ' class="current"' : '' , ' href="', $scripturl, '">' , $txt[103] , '</a></li>';

   // Show the [help] button.
   echo '<li><a' , $current_action=='help' ? ' class="current"' : '' , ' href="', $scripturl, '?action=help">' , $txt[119] , '</a></li>';
   

    // How about the [search] button?
       if ($context['allow_search'])
    echo '<li><a' , $current_action=='search' ? ' class="current"' : '' , ' href="', $scripturl, '?action=search">' , $txt[182] , '</a></li>';

Jetzt habe ich diesen Schnipsel aus dem default-Ordner:

// Aeva Media
   // Recalculate number of unseen items
   global $user_info;

   if (!empty($user_info['aeva_unseen']) && $user_info['aeva_unseen'] == -1)
   {
      global $sourcedir;
      require_once($sourcedir . '/Aeva-Subs.php');
      aeva_loadSettings();
   }

   $aeva_unseen = !allowedTo('aeva_access_unseen') || empty($user_info['aeva_unseen']) || $user_info['aeva_unseen'] == -1 ? 0 : $user_info['aeva_unseen'];

   if (allowedTo('aeva_access'))
      echo ($current_action == 'media' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '', '
            <td valign="top" class="maintab_', $current_action == 'media' ? 'active_back' : 'back', '">
               <a href="', $scripturl, '?action=media">', isset($txt['aeva_gallery']) ? $txt['aeva_gallery'] : 'Media', $aeva_unseen ? '</a> <a href="' . $scripturl . '?action=media;sa=unseen">[<b>' . $aeva_unseen . '</b>]' : '', '</a>
            </td>', $current_action == 'media' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

   // the [member] list button
   if ($context['allow_memberlist'])
      echo ($current_action == 'mlist' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td valign="top" class="maintab_' , $current_action == 'mlist' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '?action=mlist">' , $txt[331] , '</a>
            </td>' , $current_action == 'mlist' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';



Vielleicht kann mir jemand auf die Schnelle helfen, ich blick da gerade überhaupt nicht durch :)Achja, mit dem Parser hab ichs auch probiert.

Liebe Grüße
Rayy

RayyBan

  • Mitglied
  • **
  • Beiträge: 5
Re: Aeva Media - SMF 1.1.11
« Antwort #1 am: 08. Mai 2010, 20:05:03 »
Habe vergessen, mein Problem zu erwähnen:

Wenn ich diesen Code in die Datei einfüge, dann sehe ich zwar einen Media Button in meinem Forum, jedoch ist er anders formatiert und einige Button rutschen eine Zeile nach unten.
Also muss ich nur auf einen bestimmten Part in der CSS-Datei verlinken?!?

Jorin

  • Gast
Re: Aeva Media - SMF 1.1.11
« Antwort #2 am: 09. Mai 2010, 13:39:21 »
Suche in index.template.php:

Code
// Show the [help] button.
   echo '<li><a' , $current_action=='help' ? ' class="current"' : '' , ' href="', $scripturl, '?action=help">' , $txt[119] , '</a></li>';

Ersetze mit:

Code
// Show the [help] button.
   echo '<li><a' , $current_action=='help' ? ' class="current"' : '' , ' href="', $scripturl, '?action=help">' , $txt[119] , '</a></li>';

// Show the [avea] button.
   echo '<li><a' , $current_action=='media' ? ' class="current"' : '' , ' href="', $scripturl, '?action=media">Media Galerie</a></li>';

Wenn dir die Stelle nicht gefällt, musst du es eben nochmals umbauen. Ich hoffe, das Prinzip ist aber klar.

Im Wiki gibts aber auch eine schöne Anleitung:
Einen neuen Button in die Navigation einbauen

RayyBan

  • Mitglied
  • **
  • Beiträge: 5
Re: Aeva Media - SMF 1.1.11
« Antwort #3 am: 10. Mai 2010, 11:25:54 »
Vielen Dank!

Mir ist aufgefallen, dass ich in der untergeordneten Liste eine Tabellenzelle eingefügt habe.
Vielleicht hat das dafür gesorgt, dass alles ein wenig verschoben war.
Jetzt funktioniert alles bestens.

RayyBan

  • Mitglied
  • **
  • Beiträge: 5
Re: Aeva Media - SMF 1.1.11
« Antwort #4 am: 04. Oktober 2010, 10:16:44 »
Nachdem eigentlich alles soweit zum Laufen gebracht habe, hier noch ein kleines Anliegen.

Ich möchte auf meiner Website gerne ein oder mehrere Bilder aus dem Bereich "Wechselnde Einträge" anzeigen lassen.

Hat Aeva Media dafür eine eigene SSI.php?

Ich konnte leider nichts vergleichbares finden.

 

Internes

Nutzungsbedingungen Impressum

Wissenswertes

Hilfe Knowledge Base

Nützliches

Downloads Socialmedia