25. November 2017, 06:55:38
SMFPortal.de

Autor Thema: Valide  (Gelesen 642 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

19. September 2010, 03:02:21
Gelesen 642 mal

norleda


Hallo habe in meinem Forum den Validator aufgerufen dabei habe ich folgende Fehlermeldung erhalten.
Ich verwende folgendes Theme ModernDark64 sofern es mit dem Template zu tun hat.
Wo kann ich diese Fehlermeldung beseitigen? habe schon in der index.php geschaut aber dort scheint der Fehler nicht zu liegen.
Vielleicht weiß jemand von euch Rat und kann mir helfen.

Line 12, Column 11: multiple comments in comment declaration
   <![endif]-->✉
 Line 11, Column 80: Comment not terminated <!--[if lt IE 7]> <link rel="stylesheet" href="http:
…tureshowtime.com/forum-neu/Themes/ModernDark64_2rc3----/css/MenuMatic-ie6.css?…✉
 Line 11, Column 80: Comment not terminated <!--[if lt IE 7]> <link rel="stylesheet" href="http:
…tureshowtime.com/forum-neu/Themes/ModernDark64_2rc3----/css/MenuMatic-ie6.css?…


19. September 2010, 08:16:40
Antwort #1

TE

Gast
Link zum Forum wäre hilfreich, die Fehler sind aller Wahrscheinlichkeit nach in der THemes/deinTheme/Index.template.php..
so wie es aussieht ist dort eine Abfrage drin, die überprüft, ob der benutzte Browser ein IE 7 ist.. Möglicherweise ist die nicht korrekt geschlossen?
üblicherweise würde diese etwa so aussehen:
Code
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" href="iehacks.css" />
<![endif]-->

da das ein reiner IE-Code (eigentlich ein Hack) ist, kann es theoretisch auch sein, daß der Validator diesen als nicht XHTML-Konform anmeckert.
« Letzte Änderung: 19. September 2010, 08:19:16 von TE »

 

Internes

Nutzungsbedingungen Impressum

Wissenswertes

Hilfe Knowledge Base

Nützliches

Downloads Kleinanzeigen Socialmedia